Arduino cross-development kit on Gentoo.

While I’m sitting here hacking around, here’s the exact command that I needed to run to get the Arduino development kit to install properly on Windbringer:

It should be noted that I’m using Layman to manage my overlays, which is why I had to specify the environment variable on the command line.

I discovered that GCC v4.1.2 didn't support the Atmega328, which is what my Arduino Duemilanove is based upon, so I had to upgrade GCC to the latest stable release for Gentoo.  To generate code for the Atmega328, you need v4.2.2 or …

Read more...